summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-29 23:09:06 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2014-05-29 23:09:06 +0200
commitdc7e6a136e9baf98a2323758765aeab7ebae336c (patch)
tree7861d12304fc0e227334ebd6a5be64dbb01977b0 /configure.ac
parent1d1da90042d2ee7a8215dc6291b54bc1ebe59fe4 (diff)
Disable linking when cross-compiling
* configure.ac: Call AC_NO_EXECUTABLES when cross-compiling.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 873ced81..cf8590be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,6 +83,13 @@ AC_PROG_INSTALL
AC_PROG_AWK
AC_PROG_SED
+if test "x$cross_compiling" = "xyes"; then
+ # It may be that we don't have a working libc yet, for instance
+ # because we're bootstrapping the cross-compilation tool chain.
+ # Thus, use this undocumented Autoconf macro designed for this.
+ AC_NO_EXECUTABLES
+ AC_MSG_WARN("cross-compiling, disabling linking")
+fi
AC_PROG_CC
# Require GCC.
if test x$GCC != xyes; then