summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJustus Winter <4winter@informatik.uni-hamburg.de>2013-10-25 13:45:47 +0200
committerJustus Winter <4winter@informatik.uni-hamburg.de>2013-10-31 10:43:28 +0100
commit87c02e03c4ae40e5e96792f67d7aad09b7f50935 (patch)
treecd777c2998cbec7d66710dcd7f683d10bbed8c08 /configure.ac
parentaece54e2c790d65c660bfe0bbbfd42d9cdd3fe27 (diff)
configure.ac: properly escape the test for X11/keysymdef.h
* configure.ac: Properly escape the test for X11/keysymdef.h using AC_LANG_SOURCE.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6844f6cb..d822dd2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,7 +259,7 @@ PKG_CHECK_MODULES([X11], [x11 xproto],
have_keysymdef_h=no
AC_CHECK_HEADER([X11/keysymdef.h],
[AC_MSG_CHECKING([for X11/keysymdef.h absolute location])
- AC_PREPROC_IFELSE([#include <X11/keysymdef.h>],
+ AC_PREPROC_IFELSE([AC_LANG_SOURCE([[#include <X11/keysymdef.h>]])],
[[X11_KEYSYMDEF_H=`$SED -n 's%^[^"]*"\([^"]*X11/keysymdef.h\)".*$%\1%p' conftest.i`]
# did the sed magic above work?
AS_IF([test -f "$X11_KEYSYMDEF_H"],