summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2017-07-23 15:37:30 +0200
committerRichard Braun <rbraun@sceen.net>2017-07-23 15:37:30 +0200
commitf1cdd1dfbbcfbc61cb48bb30d4b612a0dc36a089 (patch)
tree00a42d7859986088a5b9d6d4c348dce9eeb55011 /Makefile.am
parent3eb18b9f2a92b9189d9298b9aa1b8547f6276639 (diff)
slist: new module
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0835ada..e44c5a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
EXTRA_DIST =
MOSTLYCLEANFILES =
+# TODO Remove tabs
AM_CPPFLAGS = \
-pipe \
-std=gnu11 \
@@ -41,6 +42,7 @@ librbraun_la_SOURCES = \
rdxtree.c \
rdxtree.h \
rdxtree_i.h \
+ slist.h \
shell.c \
shell.h \
x86/atomic.h \
@@ -54,6 +56,7 @@ bin_PROGRAMS = \
test_fmt_sprintf \
test_fmt_sscanf \
test_plist \
+ test_slist \
test_rbtree \
test_rdxtree \
test_shell
@@ -73,6 +76,9 @@ test_fmt_sscanf_LDADD = librbraun.la
test_plist_SOURCES = test/test_plist.c
test_plist_LDADD = librbraun.la
+test_slist_SOURCES = test/test_slist.c
+test_slist_LDADD = librbraun.la
+
test_rbtree_SOURCES = test/test_rbtree.c
test_rbtree_LDADD = librbraun.la