summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2015-03-12 23:26:15 +0100
committerRichard Braun <rbraun@sceen.net>2015-03-12 23:26:15 +0100
commit9a96eab8383e94da192dc3a2aa77b9bed1fb39aa (patch)
tree51186ca05bb7f7ada88ce0b2c4a3a271164cd918 /Makefile.am
parent569c0aa5807c6627761b6cf8d3f726a4b6e9535d (diff)
shell: new module
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b5d255d..39bc14b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,14 +33,17 @@ librbraun_la_SOURCES = \
rbtree_i.h \
rdxtree.c \
rdxtree.h \
- rdxtree_i.h
+ rdxtree_i.h \
+ shell.c
+ shell.h
librbraun_la_LIBADD = -lrt -lpthread
bin_PROGRAMS = \
test_avltree \
test_rbtree \
- test_rdxtree
+ test_rdxtree \
+ test_shell
test_avltree_SOURCES = test/test_avltree.c
test_avltree_LDADD = librbraun.la
@@ -50,3 +53,6 @@ test_rbtree_LDADD = librbraun.la
test_rdxtree_SOURCES = test/test_rdxtree.c
test_rdxtree_LDADD = -lrt -lpthread
+
+test_shell_SOURCES = test/test_shell.c
+test_shell_LDADD = librbraun.la