summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2017-07-24 21:42:56 +0200
committerRichard Braun <rbraun@sceen.net>2017-07-24 21:42:56 +0200
commit3e5bd919e167c0d3ae4ca407fe3d88829d0261b5 (patch)
tree24cb8b2c304cdfece15639e3466463afd12db58e /Makefile.am
parent10a647cb57a145c6b6eb91747869b26ff4f2a94a (diff)
hlist: new module
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index e3480ca..e08b181 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,6 +31,7 @@ librbraun_la_SOURCES = \
fmt.c \
fmt.h \
hash.h \
+ hlist.h \
list.c \
list.h \
macros.h \
@@ -55,11 +56,12 @@ bin_PROGRAMS = \
test_cbuf \
test_fmt_sprintf \
test_fmt_sscanf \
+ test_hlist \
test_plist \
- test_slist \
test_rbtree \
test_rdxtree \
- test_shell
+ test_shell \
+ test_slist
test_avltree_SOURCES = test/test_avltree.c
test_avltree_LDADD = librbraun.la
@@ -73,12 +75,12 @@ test_fmt_sprintf_LDADD = librbraun.la
test_fmt_sscanf_SOURCES = test/test_fmt_sscanf.c
test_fmt_sscanf_LDADD = librbraun.la
+test_hlist_SOURCES = test/test_hlist.c
+test_hlist_LDADD = librbraun.la
+
test_plist_SOURCES = test/test_plist.c
test_plist_LDADD = librbraun.la
-test_slist_SOURCES = test/test_slist.c
-test_slist_LDADD = librbraun.la
-
test_rbtree_SOURCES = test/test_rbtree.c
test_rbtree_LDADD = librbraun.la
@@ -87,3 +89,6 @@ test_rdxtree_LDADD = -lrt -lpthread
test_shell_SOURCES = test/test_shell.c
test_shell_LDADD = librbraun.la
+
+test_slist_SOURCES = test/test_slist.c
+test_slist_LDADD = librbraun.la