summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2017-03-14 21:49:19 +0100
committerRichard Braun <rbraun@sceen.net>2017-03-14 21:49:19 +0100
commitcfa548b6350e2e6e65314355f39383d549c7a0c5 (patch)
treed0e140a65d79fb036792fe4f97eddfafb79d8bf9 /configure.ac
parentb409e4e8eb18e7a6bf09a18e662f742587af40a1 (diff)
configure.ac: disable PIE if enabled by default
In order to append the required flags only if they are supported by the compiler, import a set of m4 macros from autoconf-archive.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 476331b..eb8dde7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,6 +2,7 @@ AC_INIT([X15], [0.1], [rbraun@sceen.net], [x15])
AC_CONFIG_SRCDIR([kern/config.h])
AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([tools/m4])
AM_INIT_AUTOMAKE([foreign subdir-objects 1.11])
@@ -15,6 +16,9 @@ AC_PROG_CC
AM_PROG_AS
AM_PROG_CC_C_O
+# Disable PIE if enabled by default
+AX_APPEND_COMPILE_FLAGS([-no-pie -fno-pie])
+
AC_HEADER_ASSERT()
m4_include([arch/x86/configfrag.ac])