summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2017-03-23 22:45:59 +0100
committerRichard Braun <rbraun@sceen.net>2017-03-23 23:00:27 +0100
commit5c5efc7d176a08a3486811f3a3a9c37e21e7a67d (patch)
treea37a01d3b0009691dafc47f9a2ab4578a1080746 /configure.ac
parentd7130c4ea367ed0ee560df6c0095d57ad7ccf0e0 (diff)
Make the build system handle Asciidoc documentation
Asciidoc was selected because of its text-based lightweight markup nature, its extensibility and configurability, and the range of available output formats. Most importantly, it's an acceptable way to write Unix man pages and guides. Despite the surprising lack of pre-existing autotools support, it was quite easy to implement correctly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6bd2e8b..9dd3bc0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,18 +4,24 @@ AC_CONFIG_SRCDIR([kern/config.h])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([tools/m4])
+# Artificially create the doc subdirectory since Automake apparently
+# won't do it itself.
+AC_CONFIG_COMMANDS([doc/.empty])
+
AM_INIT_AUTOMAKE([foreign subdir-objects 1.11])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])],
[AC_SUBST([AM_DEFAULT_VERBOSITY], [1])])
-AC_PREFIX_DEFAULT([])
AC_CANONICAL_HOST
AC_PROG_CPP
AC_PROG_CC
AM_PROG_AS
AM_PROG_CC_C_O
+AX_CHECK_ASCIIDOC([AC_MSG_NOTICE([asciidoc not found, not building html documentation])])
+AX_CHECK_A2X([AC_MSG_NOTICE([a2x not found, not building man pages])])
+
# Disable PIE if enabled by default
AX_APPEND_COMPILE_FLAGS([-no-pie -fno-pie])