summaryrefslogtreecommitdiff
path: root/viengoos/Makefile.am
diff options
context:
space:
mode:
authorneal <neal>2007-11-16 13:35:00 +0000
committerneal <neal>2007-11-16 13:35:00 +0000
commite46ff816c662bc8b47dfc00bbe5501dbeffd93bb (patch)
tree16603b813cf7301b85b58f28217aa188825513d8 /viengoos/Makefile.am
parent17b21c229fe9756a2e9ec158b6bdf5c2ca9869a5 (diff)
2007-11-16 Neal H. Walfield <neal@gnu.org>
* viengoos/Makefile.am: New file based on ../wortel/Makefile.am. * viengoos/headers.m4: New file. * viengoos/config.m4: New file based on ../wortel/config.m4. * viengoos/viengoos.h: New file. * viengoos/viengoos.c: New file. * viengoos/activity.h: Likewise. * viengoos/activity.c: Likewise. * viengoos/as.h: Likewise. * viengoos/as.c: Likewise. * viengoos/cap-lookup.c: Likewise. * viengoos/cap.h: Likewise. * viengoos/cap.c: Likewise. * viengoos/thread.h: New file. * viengoos/thread.c: New file. * viengoos/object.h: New file. * viengoos/object.c: New file. * viengoos/rm.h: New file. * viengoos/server.c: New file. * viengoos/server.h: New file. * viengoos/zalloc.h: Copied from ../physmem. * viengoos/zalloc.c: Copied from ../physmem. Don't include "output.h". Include <hurd/stddef.h>. Change uses of min_page_size to PAGESIZE. * viengoos/memory.h: New file. * viengoos/memory.c: New file. * viengoos/sigma0.c: Copy from ../wortel. * viengoos/sigma0.h: Copy from ../wortel. Don't include "shutdown.h". Include <hurd/stddef.h>. * viengoos/bits.h: Likewise. * viengoos/panic.c: New file. * viengoos/debug.c: Likewise. * viengoos/debug.h: Likewise. * viengoos/boot-modules.h: Likewise. * viengoos/boot-modules.c: Likewise. * viengoos/elf.h: Copied from ../wortel. * viengoos/loader.c: New file based on ../wortel/loader.c. * viengoos/loader.h: New file. * viengoos/multiboot.h: Copied from Grub. * viengoos/mmap.c: New file based on ../physmem/mmap.c. * viengoos/malloc-wrap.c: New file based on ../physmem/malloc-wrap.c. * viengoos/malloc.c: Version 2.8.3 of Doug Lea's malloc.c. * viengoos/malloc.h: Version 2.8.3 of Doug Lea's malloc.h. * viengoos/ia32-cmain.c: New file based on ../wortel/ia32-cmain.c. * viengoos/ia32-crt0.S: Copied from ../wortel. (STACK_SIZE): Use a 16 page stack. * viengoos/ia32-output.c: Copied from ../wortel. * viengoos/ia32-shutdown.c: Likewise. * viengoos/output.h: New file based on ../wortel/output.h. Include <stdarg.h>. (cprintf): New definition. (output_debug): Don't define. (debug): Don't define. * viengoos/output.c: New file based on ../wortel/output.c. Don't include <stdlib.h>. (vprintf): New function. (printf): Implement in terms of vprintf. * viengoos/output-none.c: Copied from ../wortel. * viengoos/output-serial.c: Likewise. * viengoos/output-stdio.c: New file. * viengoos/output-vga.c: Copied from ../wortel. * viengoos/shutdown.h: New file based on ../wortel/shutdown.h. Don't include "output.h". (panic): Don't define. (shutdown): Rename from this... (shutdown_machine): ... to this. * viengoos/shutdown.c: New file based on ../wortel/shutdown.c. (reset) [_L4_TEST_ENVIRONMENT]: Call abort. (halt) [_L4_TEST_ENVIRONMENT]: Call abort. (shutdown): Rename from this... (shutdown_machine): ... to this. * viengoos/t-environment.h: New file based on ../libl4/tests/environment.h. Protect from multiple inclusion. Include <hurd/stddef.h>. Include <string.h>. Include <l4/stubs.h>. (program_name): New declaration. (check_nr): Don't assume that val1 and val2 are _L4_word_t, use typeof instead. (main): Call output_init. * viengoos/t-as.c: New file.
Diffstat (limited to 'viengoos/Makefile.am')
-rw-r--r--viengoos/Makefile.am84
1 files changed, 84 insertions, 0 deletions
diff --git a/viengoos/Makefile.am b/viengoos/Makefile.am
new file mode 100644
index 0000000..1b31c27
--- /dev/null
+++ b/viengoos/Makefile.am
@@ -0,0 +1,84 @@
+# Makefile.am - Makefile template for viengoos.
+# Copyright (C) 2003, 2004, 2007 Free Software Foundation, Inc.
+# Written by Marcus Brinkmann.
+#
+# This file is part of the GNU Hurd.
+#
+# The GNU Hurd is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This GNU Hurd is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+if ARCH_IA32
+ ARCH_SOURCES = multiboot.h ia32-crt0.S ia32-cmain.c \
+ ia32-output.c output-vga.c output-serial.c ia32-shutdown.c
+endif
+
+bootdir = $(prefix)/boot
+boot_PROGRAMS = viengoos
+
+COMMON_CPPFLAGS = -I$(srcdir) -I$(top_builddir)/include \
+ -I$(top_srcdir)/libc-parts -D_GNU_SOURCE -Wall -std=gnu99 -g
+
+viengoos_CPPFLAGS = $(COMMON_CPPFLAGS) -DRM_INTERN
+viengoos_SOURCES = $(ARCH_SOURCES) \
+ output.h output.c output-none.c \
+ debug.h debug.c \
+ shutdown.h shutdown.c \
+ panic.c \
+ sigma0.h sigma0.c \
+ malloc.h malloc-wrap.c \
+ zalloc.h zalloc.c \
+ mmap.c \
+ rm.h \
+ viengoos.h viengoos.c \
+ boot-modules.h boot-modules.c \
+ memory.h memory.c \
+ object.h object.c \
+ cap.h cap.c cap-lookup.c \
+ activity.h activity.c \
+ thread.h thread.c \
+ as.h as.c \
+ bits.h \
+ elf.h loader.h loader.c \
+ server.h server.c
+
+# Doug Lea's malloc is included by malloc-wrap.c.
+EXTRA_viengoos_SOURCES = malloc.c
+
+viengoos_LDADD = -lgcc ../libc-parts/libc-parts.a \
+ ../libhurd-btree/libhurd-btree.a \
+ ../libhurd-ihash/libhurd-ihash.a
+viengoos_LDFLAGS = -u_start -e_start -N -nostdlib \
+ -Ttext=@HURD_RM_LOAD_ADDRESS@
+
+TESTS = t-as
+check_PROGRAMS = $(TESTS)
+
+t_as_CPPFLAGS = $(viengoos_CPPFLAGS) -include $(srcdir)/t-environment.h
+t_as_SOURCES = t-as.c \
+ zalloc.h zalloc.c \
+ memory.h memory.c \
+ cap.h cap.c cap-lookup.c \
+ object.h object.c \
+ activity.h activity.c \
+ thread.h thread.c \
+ as.h as.c \
+ output.h output.c output-stdio.c \
+ shutdown.h shutdown.c \
+ panic.h panic.c \
+ debug.h debug.c
+t_as_LDADD = $(viengoos_LDADD)
+
+lib_LIBRARIES = libhurd-cap.a
+libhurd_cap_a_CPPFLAGS = $(COMMON_CPPFLAGS)
+libhurd_cap_a_SOURCES = cap-lookup.c as.c as.h
+