summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormarcus <marcus>2005-01-23 21:30:40 +0000
committermarcus <marcus>2005-01-23 21:30:40 +0000
commitf4ee3163dc1cc58ce13cdef64541ffe66f5a06a9 (patch)
tree71e7d8fbe453312d4760659ae62d3bfd2dd42e1f /configure.ac
parentb31c52a9116b976a6f919ec045462807851f5988 (diff)
2005-01-23 Marcus Brinkmann <marcus@gnu.org>
* configure.ac: Fall back to libc.a on GNU/Hurd. New option --with-libc. (WITH_LIBC): New automake conditional. * Makefile.am (LIBC_SUBDIRS): New variable. (SUBDIRS): Add $(LIBC_SUBDIRS). * libc: New directory. libc/ 2005-01-23 Marcus Brinkmann <marcus@gnu.org> * Initial check-in.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 14 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fa5cffd..df89a0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,13 +72,15 @@ AC_CANONICAL_HOST
AC_MSG_CHECKING([for static GNU C library])
static_libc=libc.a
-echo $host_os
case $host_os in
gnu*)
- echo HALLO
# On the GNU/Hurd, libc.a is a linker script, the real C library
- # can be found in libcrt.a instead.
- static_libc=libcrt.a
+ # can be found in libcrt.a instead. But fall back on libc.a for
+ # cheap cross-compilation.
+ libcrta=`$CC -print-file-name=libcrt.a`
+ if test "x$libcrta" != "xlibcrt.a"; then
+ static_libc=libcrt.a
+ fi
;;
esac
STATIC_GLIBC=`$CC -print-file-name=$static_libc`
@@ -153,6 +155,13 @@ m4_include([libhurd-mm/headers.m4])
m4_include([libpthread/headers.m4])
m4_include([wortel/headers.m4])
+# Check for libc and components using it.
+
+AC_ARG_WITH([libc],
+[ --with-libc compile with the GNU C library (see libc/README)])
+AM_CONDITIONAL(WITH_LIBC, test x"${with_libc-no}" != xno)
+
+
if test "x$missing_progs" != "x"; then
AC_MSG_ERROR([The following programs were not found:$missing_progs])
fi
@@ -178,6 +187,7 @@ AC_CONFIG_FILES([Makefile
physmem/Makefile
task/Makefile
deva/Makefile
+ libc/Makefile
ruth/Makefile
doc/Makefile])
AC_OUTPUT