summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorneal <neal>2003-09-07 21:49:29 +0000
committerneal <neal>2003-09-07 21:49:29 +0000
commit103f3951ba2e4ae7c1c39ad9c7d71a1df23586c9 (patch)
tree664e015e7626d3ad633b789a46c8ec5aeaab2077 /configure.ac
parentb90d3c97c9ef64621f42e40258af9c571624f99f (diff)
/
2003-09-07 Neal H. Walfield <neal@cs.uml.edu> * configure.ac: Check for latex, dvips and ps2pdf. Bail if not found. Generate doc/Makefile. /doc/ Modularize the document by breaking each chapter into its own tex file. Integrate into the build system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 15e4228..b0051a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,20 @@ AC_PROG_CC
AM_PROG_AS
AC_PROG_RANLIB
+# Required for building the documentation
+AC_PATH_PROG([LATEX], [latex], no)
+if test "x$LATEX" = xno; then
+ missing_progs="$missing_progs latex"
+fi
+AC_PATH_PROG([DVIPS], [dvips], no)
+if test "x$DVIPS" = xno; then
+ missing_progs="$missing_progs dvips"
+fi
+AC_PATH_PROG([PS2PDF], [ps2pdf], no)
+if test "x$PS2PDF" = xno; then
+ missing_progs="$missing_progs ps2pdf"
+fi
+
# Checks for libraries.
# Checks for header files.
@@ -56,10 +70,15 @@ esac
m4_include([libhurd-slab/headers.m4])
m4_include([libhurd-ihash/headers.m4])
+if test "x$missing_progs" != "x"; then
+ AC_MSG_ERROR([The following programs were not found:$missing_progs])
+fi
+
# Checks for library functions.
AC_CONFIG_FILES([Makefile
laden/Makefile
libl4/ia32/Makefile libl4/Makefile
libhurd-slab/Makefile
- libhurd-ihash/Makefile])
+ libhurd-ihash/Makefile
+ doc/Makefile])
AC_OUTPUT