summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.ac')
-rw-r--r--sysdeps/unix/sysv/linux/configure.ac10
1 files changed, 2 insertions, 8 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.ac b/sysdeps/unix/sysv/linux/configure.ac
index 6738e2d653..13abda0a51 100644
--- a/sysdeps/unix/sysv/linux/configure.ac
+++ b/sysdeps/unix/sysv/linux/configure.ac
@@ -1,7 +1,7 @@
GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
# Local configure fragment for sysdeps/unix/sysv/linux.
-define([LIBC_LINUX_VERSION],[2.6.32])dnl
+define([LIBC_LINUX_VERSION],[3.2.0])dnl
if test -n "$sysheaders"; then
OLD_CPPFLAGS=$CPPFLAGS
CPPFLAGS="$CPPFLAGS $SYSINCLUDES"
@@ -33,7 +33,7 @@ fi
# set arch_minimum_kernel already, let that override our defaults here.
# Note that we presume such a fragment has set libc_cv_gcc_unwind_find_fde
# if appropriate too.
-test -n "$arch_minimum_kernel" || arch_minimum_kernel=2.6.32
+test -n "$arch_minimum_kernel" || arch_minimum_kernel=3.2.0
if test -n "$minimum_kernel"; then
changequote(,)
user_version=$((`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1 \* 65536 + \2 \* 256 + \3/'`))
@@ -65,12 +65,6 @@ else
*** compatible kernel version])
fi
-# Until we start requiring 2.6.37+ headers, we need to check for the
-# availability of linux/fanotify.h for testing purposes.
-AC_CHECK_HEADER(linux/fanotify.h,
- [AC_DEFINE(HAVE_LINUX_FANOTIFY_H)], ,
- [/* No default includes. */])
-
if test -n "$sysheaders"; then
CPPFLAGS=$OLD_CPPFLAGS
fi