summaryrefslogtreecommitdiff
path: root/sysdeps/mach/hurd/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/mach/hurd/configure.ac')
-rw-r--r--sysdeps/mach/hurd/configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysdeps/mach/hurd/configure.ac b/sysdeps/mach/hurd/configure.ac
index af9a9ea052..774ffc80a9 100644
--- a/sysdeps/mach/hurd/configure.ac
+++ b/sysdeps/mach/hurd/configure.ac
@@ -1,7 +1,9 @@
GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
dnl We need this setting because of the need for PLT calls in ld.so.
-AC_DEFINE([NO_HIDDEN])
+dnl See Roland's comment in
+dnl https://sourceware.org/bugzilla/show_bug.cgi?id=15605
+AC_DEFINE([NO_RTLD_HIDDEN])
if test -n "$sysheaders"; then
OLD_CPPFLAGS=$CPPFLAGS
@@ -24,3 +26,7 @@ fi
if test -n "$sysheaders"; then
CPPFLAGS=$OLD_CPPFLAGS
fi
+
+dnl ifunc does not work yet for static binaries
+dnl http://www.gnu.org/software/hurd/open_issues/ifunc.html
+libc_cv_ld_gnu_indirect_function=no