summaryrefslogtreecommitdiff
path: root/sysdeps/i386/elf/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/i386/elf/configure.in')
-rw-r--r--sysdeps/i386/elf/configure.in28
1 files changed, 28 insertions, 0 deletions
diff --git a/sysdeps/i386/elf/configure.in b/sysdeps/i386/elf/configure.in
new file mode 100644
index 0000000000..d7e1704540
--- /dev/null
+++ b/sysdeps/i386/elf/configure.in
@@ -0,0 +1,28 @@
+sinclude(./aclocal.m4)dnl Autoconf lossage
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+# Local configure fragment for sysdeps/unix/sysv/linux.
+
+# Check for support of thread-local storage handling in assembler and
+# linker.
+AC_CACHE_CHECK(for i386 TLS support, libc_cv_386_tls, [dnl
+cat > conftest.s <<\EOF
+ .section ".tdata", "awT", @progbits
+foo: .long 1
+ .section ".tbss", "awT", @nobits
+ .comm bar,4,4
+ .text
+baz: leal bar@TLSLDM(%ebx), %eax
+ leal bar@DTPOFF(%eax), %edx
+ subl foo@GOTTPOFF(%edx), %eax
+ subl $bar@TPOFF, %eax
+EOF
+dnl
+if AC_TRY_COMMAND(${CC-cc} -c $CFLAGS conftest.s 1>&AC_FD_CC); then
+ libc_cv_386_tls=yes
+else
+ libc_cv_386_tls=no
+fi
+rm -f conftest*])
+if test $libc_cv_386_tls = yes; then
+ AC_DEFINE(HAVE_TLS_SUPPORT)
+fi