summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2000-12-01 23:15:18 +0000
committerUlrich Drepper <drepper@redhat.com>2000-12-01 23:15:18 +0000
commitdeb7f0b41f9c892ba7413abcc4cd5f19787a1122 (patch)
treeb5e72ddc8e44d6d7d6d49af0254cb6b9cf919a17 /configure.in
parent6b3f2b3d3ab0435afd7422c6ab38479bb5b1ba70 (diff)
Regenerated: autoconf configure.in
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 97240bcc43..ed15555834 100644
--- a/configure.in
+++ b/configure.in
@@ -82,6 +82,17 @@ AC_ARG_WITH(headers, dnl
[default=compiler default]],
sysheaders=$withval, sysheaders='')
+AC_ARG_WITH(oldest-abi, dnl
+[ --with-oldest-abi=ABI the oldest ABI supported [e.g. 2.2]
+ [default=glibc default]],
+ oldest_abi=$withval, oldest_abi='')
+if test ! -z "$oldest_abi"; then
+ AC_DEFINE_UNQUOTED(GLIBC_OLDEST_ABI, "$oldest_abi")
+else
+ oldest_abi=default
+fi
+AC_SUBST(oldest_abi)
+
AC_ARG_ENABLE(libio, dnl
[ --enable-libio build in GNU libio instead of GNU stdio],
[if test $enableval = yes; then