summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCarlos O'Donell <carlos@systemhalted.org>2012-06-22 14:58:19 +0000
committerCarlos O'Donell <carlos@systemhalted.org>2012-06-22 18:05:23 +0000
commit0e3933b96344ab9c0ac633c19f4ebfdede5375d4 (patch)
tree764a387ce8a22e9aa401f50f0c853d7d2e989e1b /configure.in
parent807841933bed6a3a308451a05f502de28aa6c6b8 (diff)
Use AC_LANG_SOURCE to fix autoconf warnings.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4fe09c488c..5028e6411e 100644
--- a/configure.in
+++ b/configure.in
@@ -278,12 +278,12 @@ if test "x$systemtap" != xno; then
AC_CACHE_CHECK([for systemtap static probe support], libc_cv_sdt, [dnl
old_CFLAGS="$CFLAGS"
CFLAGS="-std=gnu99 $CFLAGS"
- AC_COMPILE_IFELSE([#include <sys/sdt.h>
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[#include <sys/sdt.h>
void foo (int i, void *p)
{
asm ("" STAP_PROBE_ASM (foo, bar, STAP_PROBE_ASM_TEMPLATE (2)) ""
:: STAP_PROBE_ASM_OPERANDS (2, i, p));
-}], [libc_cv_sdt=yes], [libc_cv_sdt=no])
+}]])], [libc_cv_sdt=yes], [libc_cv_sdt=no])
CFLAGS="$old_CFLAGS"])
if test $libc_cv_sdt = yes; then
AC_DEFINE([USE_STAP_PROBE])