summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-11-03 13:03:52 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-11-03 13:03:52 +0000
commitcf09d0b052cbbfbcabc3c3d78d485876b9b81f9c (patch)
tree60cb1e41f7c5b11e9c3a7d1a525e6eb96b961f9b /configure.ac
parentd86812df5ae27d1695829966916ba26ea7df3d2f (diff)
Remove --no-whole-archive configure test.
There is a configure test for the --no-whole-archive linker option. This option was added in binutils 2.7, so the test is obsolete; this patch removes it. Tested for x86_64 and x86 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_ld_no_whole_archive): Remove configure test. * configure: Regenerated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index d4aa67fb74..c3ebba3918 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1423,25 +1423,6 @@ if test $libc_cv_have_section_quotes = yes; then
AC_DEFINE(HAVE_SECTION_QUOTES)
fi
-AC_CACHE_CHECK(for ld --no-whole-archive, libc_cv_ld_no_whole_archive, [dnl
-cat > conftest.c <<\EOF
-_start () {}
-int __eh_pc;
-__throw () {}
-EOF
-dnl No \ in command here because it ends up inside ''.
-if AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS
- -nostdlib -nostartfiles -Wl,--no-whole-archive
- -o conftest conftest.c 1>&AS_MESSAGE_LOG_FD]); then
- libc_cv_ld_no_whole_archive=yes
-else
- libc_cv_ld_no_whole_archive=no
-fi
-rm -f conftest*])
-if test $libc_cv_ld_no_whole_archive = no; then
- AC_MSG_ERROR([support for --no-whole-archive is needed])
-fi
-
AC_CACHE_CHECK(for __builtin_memset, libc_cv_gcc_builtin_memset, [dnl
cat > conftest.c <<\EOF
void zero (void *x)