summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Weimer <fweimer@redhat.com>2017-06-13 22:09:59 +0200
committerFlorian Weimer <fweimer@redhat.com>2017-06-13 22:24:38 +0200
commitc2528fef3b05bcffb1ac27c6c09cc3ff24b7f03f (patch)
tree9e296ef903992b729d017359d4b914a6086c0ee3 /configure.ac
parentf8bf87face3304f216bcd838081fa33bb4976ac6 (diff)
configure: Suppress expected compiler error message
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d74bd4490c..3f486d6df4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1187,7 +1187,8 @@ AC_SUBST(CXX_SYSINCLUDES)
# copy of those headers in Makerules.
if test -n "$CXX"; then
find_cxx_header () {
- echo "#include <$1>" | $CXX -M -MP -x c++ - | sed -n "\,$1:,{s/:\$//;p}"
+ echo "#include <$1>" | $CXX -M -MP -x c++ - 2>/dev/null \
+ | sed -n "\,$1:,{s/:\$//;p}"
}
CXX_CSTDLIB_HEADER="$(find_cxx_header cstdlib)"
CXX_CMATH_HEADER="$(find_cxx_header cmath)"