summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-11-06 13:20:26 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-11-06 13:21:51 +0000
commitb9eaf28a640bdfbfbad55cdfe0361339664ab8ba (patch)
tree8cd6d06fc7ac783f43e614dbf33d974772e2bb49 /configure.ac
parent8c77b6ad4063534fb1e5a6904217c4586060334a (diff)
Remove configure tests for some linker -z options.
There are configure tests for the linker -z nodelete, -z nodlopen and -z initfirst options. These options were added in binutils 2.11, so the tests are obsolete; this patch removes them. Tested for x86_64 and x86 (testsuite, and that installed shared libraries are unchanged by the patch). * configure.ac (libc_cv_z_nodelete): Remove configure test. (libc_cv_z_nodlopen): Likewise. (libc_cv_z_initfirst): Likewise. * configure: Regenerated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index c3ebba3918..3fdf992f79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1208,18 +1208,6 @@ if test $libc_cv_cc_with_libunwind = yes; then
AC_DEFINE(HAVE_CC_WITH_LIBUNWIND)
fi
-LIBC_LINKER_FEATURE([-z nodelete], [-Wl,--enable-new-dtags,-z,nodelete],
- [libc_cv_z_nodelete=yes],
- [AC_MSG_ERROR(linker with -z nodelete support required)])
-
-LIBC_LINKER_FEATURE([-z nodlopen], [-Wl,--enable-new-dtags,-z,nodlopen],
- [libc_cv_z_nodlopen=yes],
- [AC_MSG_ERROR(linker with -z nodlopen support required)])
-
-LIBC_LINKER_FEATURE([-z initfirst], [-Wl,--enable-new-dtags,-z,initfirst],
- [libc_cv_z_initfirst=yes],
- [AC_MSG_ERROR(linker with -z initfirst support required)])
-
ASFLAGS_config=
AC_CACHE_CHECK(whether --noexecstack is desirable for .S files,
libc_cv_as_noexecstack, [dnl