summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2013-12-16 11:25:04 +1000
committerAllan McRae <allan@archlinux.org>2013-12-16 11:26:49 +1000
commit8894bad34cc9c11e89ee2594f2d75893edb1d96c (patch)
treece779812aec9cf0d3933e78695d6643b9dc5a9dc /configure.ac
parent73616a74274223356c99dda66234f54932bb8c16 (diff)
Add --enable-maintainer-mode configure option
Autoconf is tested for and run if needed only when --enable-maintainer-mode is used on configure. This results in the autom4te.cache directory only being written in the source directory during configure if automatic autoconf usage is requested. Fixes BZ #14120.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 24 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 6da8efd861..662aaa51ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,6 +231,12 @@ AC_ARG_ENABLE([force-install],
[force_install=yes])
AC_SUBST(force_install)
+AC_ARG_ENABLE([maintainer-mode],
+ AC_HELP_STRING([--enable-maintainer-mode],
+ [enable make rules and dependencies not useful (and sometimes confusing) to the casual installer]),
+ [maintainer=$enableval],
+ [maintainer=no])
+
dnl On some platforms we allow dropping compatibility with all kernel
dnl versions.
AC_ARG_ENABLE([kernel],
@@ -1004,22 +1010,24 @@ AC_CHECK_PROG_VER(AWK, gawk, --version,
AC_CHECK_TOOL(NM, nm, false)
-AC_CHECK_PROGS(AUTOCONF, autoconf, no)
-case "x$AUTOCONF" in
-xno|x|x:) AUTOCONF=no ;;
-*)
- AC_CACHE_CHECK(dnl
-whether $AUTOCONF${ACFLAGS:+ }$ACFLAGS works, libc_cv_autoconf_works, [dnl
- if (cd $srcdir; $AUTOCONF $ACFLAGS configure.ac > /dev/null 2>&1); then
- libc_cv_autoconf_works=yes
- else
- libc_cv_autoconf_works=no
- fi])
- test $libc_cv_autoconf_works = yes || AUTOCONF=no
- ;;
-esac
-if test "x$AUTOCONF" = xno; then
- aux_missing="$aux_missing autoconf"
+if test "x$maintainer" = "xyes"; then
+ AC_CHECK_PROGS(AUTOCONF, autoconf, no)
+ case "x$AUTOCONF" in
+ xno|x|x:) AUTOCONF=no ;;
+ *)
+ AC_CACHE_CHECK(dnl
+ whether $AUTOCONF${ACFLAGS:+ }$ACFLAGS works, libc_cv_autoconf_works, [dnl
+ if (cd $srcdir; $AUTOCONF $ACFLAGS configure.ac > /dev/null 2>&1); then
+ libc_cv_autoconf_works=yes
+ else
+ libc_cv_autoconf_works=no
+ fi])
+ test $libc_cv_autoconf_works = yes || AUTOCONF=no
+ ;;
+ esac
+ if test "x$AUTOCONF" = xno; then
+ aux_missing="$aux_missing autoconf"
+ fi
fi
test -n "$critic_missing" && AC_MSG_ERROR([