summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-01-15 19:57:36 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-17 15:24:54 -0500
commit4e58b6485989a9462e88d5f683e2100902afd574 (patch)
tree72c98f9647b94f8fb608e1aafedd16ca8f47f374 /configure.ac
parent214a44f3949624623bd9f5ced82a47915259324e (diff)
configure: make the unsupported error message less hostile
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 6 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index ee7a3f16a0..3c766b7409 100644
--- a/configure.ac
+++ b/configure.ac
@@ -579,9 +579,6 @@ AC_SUBST(add_on_subdirs)
###
-### I put this here to prevent those annoying emails from people who cannot
-### read and try to compile glibc on unsupported platforms. --drepper
-###
### By using the undocumented --enable-hacker-mode option for configure
### one can skip this test to make the configuration not fail for unsupported
### platforms.
@@ -591,13 +588,12 @@ if test -z "$enable_hacker_mode" && test x"$libc_config_ok" != xyes; then
*-linux* | *-gnu*)
;;
*)
- echo "*** The GNU C library is currently not available for this platform."
- echo "*** So far nobody cared to port it and if there is no volunteer it"
- echo "*** might never happen. So, if you have interest to see glibc on"
- echo "*** this platform visit"
- echo "*** http://www.gnu.org/software/libc/porting.html"
- echo "*** and join the group of porters"
- exit 1
+ AC_MSG_ERROR([
+*** The GNU C library is currently unavailable for this platform.
+*** If you are interested in seeing glibc on this platform visit
+*** the "How to submit a new port" in the wiki:
+*** https://sourceware.org/glibc/wiki/#Development
+*** and join the community!])
;;
esac
fi