summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSiddhesh Poyarekar <siddhesh@sourceware.org>2017-06-15 15:12:54 +0530
committerSiddhesh Poyarekar <siddhesh@sourceware.org>2017-06-15 15:12:54 +0530
commit2c0b90ab443abc967cbf75add4f7fde84978cb95 (patch)
tree600ed279223cf8a1e3a28bf623309fe9a51a6f8e /configure.ac
parent0edbf1230131dfeb03d843d2859e2104456fad80 (diff)
Enable tunables by default
All of the major architectures are adopting tunables as a way to add tuning to the library, from hwcap_mask for aarch64 to HLE for s390 and ifunc and cache geometry for x86. Given this adoption and the fact that we don't want additional tuning knobs to be added outside of tunables, it makes sense to enable tunables by default using this trivial patch. Smoke tested on x86 to ensure that tunables code was built without specifying it as a configure flag. I have kept it as --enabled and not changed it to --disable since we want to still keep the option of different kinds of front-ends for tunables. * configure.ac(--enable-tunables): Enable by default. * configure: Regenerate. * NEWS: Mention change. * manual/install.texi (enable-tunables): Adjust documentation. * INSTALL: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3f486d6df4..4c0a18edd9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,7 +436,7 @@ AC_ARG_ENABLE([tunables],
[AS_HELP_STRING([--enable-tunables],
[Enable tunables support. Known values are 'yes', 'no' and 'valstring'])],
[have_tunables=$enableval],
- [have_tunables=no])
+ [have_tunables=yes])
AC_SUBST(have_tunables)
if test "$have_tunables" = yes; then
AC_DEFINE(HAVE_TUNABLES)