summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorneal <neal>2008-01-17 14:10:32 +0000
committerneal <neal>2008-01-17 14:10:32 +0000
commit9875e6162f829a2a23e9578c27b5316e26edbdcc (patch)
tree1260b9f6f5b8f0ba2fb6f02618fa4c0ca4c9dde6 /Makefile.am
parent00eef7a0458f6a8c3930a4640ddce0b385a16081 (diff)
/
2008-01-17 Neal H. Walfield <neal@gnu.org> * configure.ac: Check for ln. Add new option --with-newlib. Generate newlib/Makefile. * Makefile.am (NEWLIB_SUBDIRS): New variable. (SUBDIRS): Add it. * newlib: New directory. newlib/ 2008-01-17 Neal H. Walfield <neal@gnu.org> * .cvsignore: New file. * ChangeLog: New file mentioning itself. * Makefile.am: New file. * README: Likewise. * addon: New directory. * patches: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f609de..80b7503 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# Makefile.am - Makefile template for hurd-l4.
-# Copyright (C) 2003, 2004, 2005, 2007 Free Software Foundation, Inc.
+# Copyright (C) 2003, 2004, 2005, 2007, 2008 Free Software Foundation, Inc.
# Written by Marcus Brinkmann.
#
# This file is part of the GNU Hurd.
@@ -24,11 +24,17 @@ else
LIBC_SUBDIRS =
endif
+if WITH_NEWLIB
+ NEWLIB_SUBDIRS = newlib
+else
+ NEWLIB_SUBDIRS =
+endif
+
SUBDIRS = libl4 platform \
hurd libhurd-ihash libhurd-btree libbitarray \
libhurd-slab \
libpthread \
libhurd-mm \
libc-parts laden viengoos ruth \
- $(LIBC_SUBDIRS) \
+ $(LIBC_SUBDIRS) $(NEWLIB_SUBDIRS) \
doc