summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authormarcus <marcus>2004-10-28 04:12:17 +0000
committermarcus <marcus>2004-10-28 04:12:17 +0000
commit363029cb103fc990e4696333f41e34bb9b7e9fd0 (patch)
tree0da4268e175269b1c08b04a0a0df15be3b15831b /Makefile.am
parent9eea2a623a79c362ed88954c68fce82361758150 (diff)
2004-10-28 Marcus Brinkmann <marcus@gnu.org>
* deva: New directory. * configure.ac (AC_CONFIG_FILES): Add deva/Makefile. * Makefile.am (SUBDIRS): Add deva. deva/ 2004-10-28 Marcus Brinkmann <marcus@gnu.org> * Initial check-in. physmem/ 2004-10-28 Marcus Brinkmann <marcus@gnu.org> * physmem.c (get_task_cap): Removed. (bootstrap_final): New function. (main): Call bootstrap_final, not get_task_cap. task/ 2004-10-28 Marcus Brinkmann <marcus@gnu.org> * task.c (bootstrap_final): New function. (main): Call bootstrap_final. wortel/ 2004-10-28 Marcus Brinkmann <marcus@gnu.org> * wortel.h: Include <stdbool.h>. (WORTEL_MSG_GET_TASK_CAP): Renamed into WORTEL_MSG_BOOTSTRAP_FINAL. (WORTEL_MSG_GET_DEVA_CAP_REQUEST, WORTEL_MSG_GET_DEVA_CAP_REPLY): Define new macros. (wortel_get_deva_cap_request, wortel_get_deva_cap_reply, wortel_bootstrap_final): New functions. (wortel_get_task_cap): Removed. * wortel.c (start_elf, start_deva): New functions. (start_task): Bunch of it is now in start_elf. (serve_bootstrap_requests): Handle WORTEL_MSG_BOOTSTRAP_FINAL, not WORTEL_MSG_GET_TASK_CAP. Implement support for starting deva. Implement WORTEL_MSG_GET_DEVA_CAP_REQUEST and WORTEL_MSG_GET_DEVA_CAP_REPLY. * wortel-intern.h (struct wortel_module): New member deva.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 662cecf..47a1f12 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
SUBDIRS = libl4 hurd libhurd-ihash libhurd-slab \
libhurd-cap libhurd-cap-server \
libpthread \
- libc-parts laden wortel physmem task \
+ libc-parts laden wortel physmem task deva \
doc