summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3e6dfcf..65737be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,9 +3,11 @@
libexec_PROGRAMS = migcom
bin_SCRIPTS = mig
+AM_YFLAGS = -d
+
EXTRA_DIST = gensym.awk cpu.sym
-CLEANFILES = cpu.h *.sym[co] lexxer.c parser.c
+CLEANFILES = cpu.h *.sym[co] lexxer.c parser.c parser.h
AWK_V = $(AWK_V_$(V))
AWK_V_ = $(AWK_V_$(AM_DEFAULT_VERBOSITY))
@@ -29,6 +31,8 @@ SUFFIXES = .h .symo .symc .sym
$< > $@
cpu.symc: $(srcdir)/gensym.awk
+lexxer.c: parser.h
+
$(migcom_OBJECTS): cpu.h
#