summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlavio Cruz <flaviocruz@gmail.com>2016-03-14 16:22:34 -0400
committerJustus Winter <justus@gnupg.org>2016-03-15 18:59:25 +0100
commit8023ec242f1442159ba68d793447b9b3dc8db0aa (patch)
treefcd710d2085b45fc1c36b359f36e0b51399d09c6 /Makefile.am
parent95a729b9dd53b0486789a80c1775c987f87dd0f2 (diff)
Automatically generate parser.h.
* Makefile.am: Set AM_YFLAGS to -d to generate parser.h. Add parser.h to CLEANFILES and include parser.h as a dependency of lexxer.c. * lexxer.l: Declare yyerror here. * parser.h: Remove file since yacc will generate the same content automatically.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3e6dfcf..65737be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,9 +3,11 @@
libexec_PROGRAMS = migcom
bin_SCRIPTS = mig
+AM_YFLAGS = -d
+
EXTRA_DIST = gensym.awk cpu.sym
-CLEANFILES = cpu.h *.sym[co] lexxer.c parser.c
+CLEANFILES = cpu.h *.sym[co] lexxer.c parser.c parser.h
AWK_V = $(AWK_V_$(V))
AWK_V_ = $(AWK_V_$(AM_DEFAULT_VERBOSITY))
@@ -29,6 +31,8 @@ SUFFIXES = .h .symo .symc .sym
$< > $@
cpu.symc: $(srcdir)/gensym.awk
+lexxer.c: parser.h
+
$(migcom_OBJECTS): cpu.h
#