summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in27
1 files changed, 16 insertions, 11 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
index 15637fae76..7d87ef5207 100644
--- a/sysdeps/unix/sysv/linux/configure.in
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -9,18 +9,23 @@ test $stdio = default && stdio=libio
# existing system library, because we are the only system library.
inhibit_glue=yes
-AC_CACHE_CHECK(installed Linux kernel header files, libc_cv_linux201, [dnl
+define([LIBC_LINUX_VERSION],[2.0.3])dnl
+define([libc_cv_linuxVER], [libc_cv_linux]patsubst(LIBC_LINUX_VERSION,[\.]))dnl
+AC_CACHE_CHECK(installed Linux kernel header files, libc_cv_linuxVER, [dnl
AC_TRY_COMPILE([#include <linux/version.h>],
-[#if LINUX_VERSION_CODE < (2 *65536+ 0 *256+ 1) /* 2.0.1 */
+[#if LINUX_VERSION_CODE < ]dnl
+patsubst(LIBC_LINUX_VERSION,[^\([^.]*\)\.\([^.]*\)\.\([^.]*\)$],dnl
+[ (\1 *65536+ \2 *256+ \3) /* \1.\2.\3 */])[
eat flaming death
#endif],
- libc_cv_linux201='2.0.1 or later',
- libc_cv_linux201='TOO OLD!')])
-if test "$libc_cv_linux201" != '2.0.1 or later'; then
- AC_MSG_ERROR([GNU libc requires kernel header files from Linux 2.0.1
-or later to be installed before configuring. The kernel header files
-are found usually in /usr/include/asm and /usr/include/linux; make sure
-these directories use files from Linux 2.0.1 or later. This check uses
-<linux/version.h>, so make sure that file was built correctly when
-installing the kernel header files.])
+ libc_cv_linuxVER='LIBC_LINUX_VERSION or later',
+ libc_cv_linuxVER='TOO OLD!')])
+if test "$libc_cv_linuxVER" != 'LIBC_LINUX_VERSION or later'; then
+ AC_MSG_ERROR([GNU libc requires kernel header files from
+Linux LIBC_LINUX_VERSION or later to be installed before configuring.
+The kernel header files are found usually in /usr/include/asm and
+/usr/include/linux; make sure these directories use files from
+Linux LIBC_LINUX_VERSION or later. This check uses <linux/version.h>, so
+make sure that file was built correctly when installing the kernel header
+files.])
fi