summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.ac')
-rw-r--r--sysdeps/unix/sysv/linux/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.ac b/sysdeps/unix/sysv/linux/configure.ac
index 1be921f65e..90cbf4894d 100644
--- a/sysdeps/unix/sysv/linux/configure.ac
+++ b/sysdeps/unix/sysv/linux/configure.ac
@@ -105,6 +105,12 @@ else
*** compatible kernel version])
fi
+# Until we start requiring 2.6.37+ headers, we need to check for the
+# availability of linux/fanotify.h for testing purposes.
+AC_CHECK_HEADER(linux/fanotify.h,
+ [AC_DEFINE(HAVE_LINUX_FANOTIFY_H)], ,
+ [/* No default includes. */])
+
# The result of the above test for the use of the FDE code is invalid if
# the user overrides the decision about the minimum ABI.
if test "$oldest_abi" != default && test "2.2.4" \< "$oldest_abi"; then