summaryrefslogtreecommitdiff
path: root/sysdeps/mach/hurd/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/mach/hurd/configure.in')
-rw-r--r--sysdeps/mach/hurd/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/sysdeps/mach/hurd/configure.in b/sysdeps/mach/hurd/configure.in
new file mode 100644
index 0000000000..39e1002d6e
--- /dev/null
+++ b/sysdeps/mach/hurd/configure.in
@@ -0,0 +1,19 @@
+sinclude(./aclocal.m4)dnl Autoconf lossage.
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+
+# If configure is passed `--with-hurd=DIR', set `hurd-srcdir' to DIR in
+# config.make.
+
+AC_ARG_WITH(hurd, dnl
+[ --with-hurd=DIRECTORY find Hurd source code in DIRECTORY [../hurd]],
+ [dnl
+case z"$with_hurd" in
+z | zno | zyes) ;; # Not specified, or specified with no value.
+z*) config_vars="$config_vars
+hurd-srcdir = $with_hurd" ;;
+esac
+])
+
+# Don't bother trying to generate any glue code to be compatible with the
+# existing system library, because we are the only system library.
+inhibit_glue=yes