summaryrefslogtreecommitdiff
path: root/sysdeps/mach/hurd/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/mach/hurd/configure.ac')
-rw-r--r--sysdeps/mach/hurd/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/sysdeps/mach/hurd/configure.ac b/sysdeps/mach/hurd/configure.ac
index b1f16a569e..af9a9ea052 100644
--- a/sysdeps/mach/hurd/configure.ac
+++ b/sysdeps/mach/hurd/configure.ac
@@ -3,6 +3,11 @@ GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
dnl We need this setting because of the need for PLT calls in ld.so.
AC_DEFINE([NO_HIDDEN])
+if test -n "$sysheaders"; then
+ OLD_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $SYSINCLUDES"
+fi
+
AC_CACHE_CHECK(Hurd header version, libc_cv_hurd_version, [dnl
AC_TRY_COMPILE(dnl
[#include <hurd/version.h>], [
@@ -15,3 +20,7 @@ AC_TRY_COMPILE(dnl
if test "x$libc_cv_hurd_version" != xok; then
AC_MSG_ERROR(Hurd headers not installed or too old)
fi
+
+if test -n "$sysheaders"; then
+ CPPFLAGS=$OLD_CPPFLAGS
+fi