summaryrefslogtreecommitdiff
path: root/sysdeps/mach/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/mach/configure.in')
-rw-r--r--sysdeps/mach/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/sysdeps/mach/configure.in b/sysdeps/mach/configure.in
index 058a2a05c8..05dc45b61d 100644
--- a/sysdeps/mach/configure.in
+++ b/sysdeps/mach/configure.in
@@ -59,3 +59,12 @@ done
if test "x$mach_interface_list" = x; then
AC_MSG_ERROR([what manner of Mach is this?])
fi
+
+AC_CACHE_CHECK(for host_page_size in mach_host.defs,
+ libc_cv_mach_host_page_size, [dnl
+AC_EGREP_HEADER(host_page_size, mach/mach_host.defs,
+ libc_cv_mach_host_page_size=yes,
+ libc_cv_mach_host_page_size=no)])
+if test $libc_cv_mach_host_page_size = yes; then
+ AC_DEFINE([HAVE_HOST_PAGE_SIZE])
+fi