summaryrefslogtreecommitdiff
path: root/sysdeps/arm/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/arm/configure.ac')
-rw-r--r--sysdeps/arm/configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/sysdeps/arm/configure.ac b/sysdeps/arm/configure.ac
index 859c92a002..90cdd69c75 100644
--- a/sysdeps/arm/configure.ac
+++ b/sysdeps/arm/configure.ac
@@ -26,19 +26,6 @@ else
LIBC_CONFIG_VAR([default-abi], [soft])
fi
-AC_CACHE_CHECK([whether the build tools support the GNU descriptor TLS scheme],
- [libc_cv_arm_tls_desc],
- [old_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -mtls-dialect=gnu2"
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([asm (".word\tfoo(tlsdesc)");], [])],
- [libc_cv_arm_tls_desc=yes], [libc_cv_arm_tls_desc=no])
- CFLAGS="$old_CFLAGS"])
-if test $libc_cv_arm_tls_desc = yes; then
- LIBC_CONFIG_VAR([have-arm-tls-desc], [yes])
-else
- LIBC_CONFIG_VAR([have-arm-tls-desc], [no])
-fi
-
AC_CACHE_CHECK([whether PC-relative relocs in movw/movt work properly],
libc_cv_arm_pcrel_movw, [
cat > conftest.s <<\EOF
@@ -123,9 +110,3 @@ libc_cv_gcc_unwind_find_fde=no
# Remove -fno-unwind-tables that was added in sysdeps/arm/preconfigure.ac.
CFLAGS=${CFLAGS% -fno-unwind-tables}
-
-dnl The normal configure check for gcc -fexecptions fails because it can't
-dnl find __aeabi_unwind_cpp_pr0. Work around this here; our GCC definitely
-dnl has -fexceptions.
-libc_cv_gcc_exceptions=yes
-exceptions=-fexceptions