summaryrefslogtreecommitdiff
path: root/ports/sysdeps/unix/sysv/linux/m68k/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports/sysdeps/unix/sysv/linux/m68k/Makefile')
-rw-r--r--ports/sysdeps/unix/sysv/linux/m68k/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/ports/sysdeps/unix/sysv/linux/m68k/Makefile b/ports/sysdeps/unix/sysv/linux/m68k/Makefile
new file mode 100644
index 0000000000..97d95847ff
--- /dev/null
+++ b/ports/sysdeps/unix/sysv/linux/m68k/Makefile
@@ -0,0 +1,23 @@
+# Linux/m68k uses Motorola asm syntax and the ELF format.
+
+m68k-syntax-flag = -DMOTOROLA_SYNTAX
+
+ifeq ($(subdir),csu)
+sysdep_routines += m68k-helpers
+endif
+
+ifeq ($(subdir),misc)
+sysdep_routines += mremap
+sysdep_headers += sys/reg.h
+endif
+
+ifeq ($(subdir),elf)
+sysdep_routines += dl-vdso libc-m68k-vdso
+sysdep-rtld-routines += m68k-vdso
+sysdep-others += lddlibc4
+install-bin += lddlibc4
+endif
+
+ifeq ($(subdir),resource)
+sysdep_routines += oldgetrlimit64
+endif