summaryrefslogtreecommitdiff
path: root/ports/sysdeps/alpha/soft-fp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports/sysdeps/alpha/soft-fp/Makefile')
-rw-r--r--ports/sysdeps/alpha/soft-fp/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/ports/sysdeps/alpha/soft-fp/Makefile b/ports/sysdeps/alpha/soft-fp/Makefile
new file mode 100644
index 0000000000..5410a78984
--- /dev/null
+++ b/ports/sysdeps/alpha/soft-fp/Makefile
@@ -0,0 +1,10 @@
+# Software floating-point emulation.
+
+ifeq ($(subdir),soft-fp)
+sysdep_routines += ots_add ots_sub ots_mul ots_div ots_cmp ots_cmpe \
+ ots_cvtxq ots_cvtqx ots_cvtqux ots_cvttx ots_cvtxt ots_nintxq
+endif
+
+ifeq ($(subdir),math)
+CPPFLAGS += -I../soft-fp
+endif