summaryrefslogtreecommitdiff
path: root/linuxthreads/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'linuxthreads/configure.in')
-rw-r--r--linuxthreads/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/linuxthreads/configure.in b/linuxthreads/configure.in
new file mode 100644
index 0000000000..3f9904a411
--- /dev/null
+++ b/linuxthreads/configure.in
@@ -0,0 +1,14 @@
+GLIBC_PROVIDES dnl See top-level configure.in.
+
+# LinuxThreads fragment for GNU C library configure mechanism.
+# This is a shell script fragment sourced by the main configure script.
+
+for other in $add_ons; do
+ test $other = nptl || continue
+ if test $add_ons_automatic = yes; then
+ AC_MSG_RESULT($libc_add_on disabled because $other add-on is also in use)
+ libc_add_on=
+ else
+ AC_MSG_ERROR(cannot use both $libc_add_on and $other add-ons in one build)
+ fi
+done