summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ec87736095..3f810bd1a8 100644
--- a/configure.in
+++ b/configure.in
@@ -88,7 +88,12 @@ AC_CONFIG_SUBDIRS($add_ons)
add_ons_pfx=
if test x"$add_ons" != x; then
for f in $add_ons; do
- add_ons_pfx="$add_ons_pfx $f/"
+ # Test whether such a subdir really exists.
+ if test -d $srcdir/$f; then
+ add_ons_pfx="$add_ons_pfx $f/"
+ else
+ AC_MSG_ERROR(add-on directory \"$f\" does not exist)
+ fi
done
fi