summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index 7b17d88528..f3e97798e6 100644
--- a/configure.in
+++ b/configure.in
@@ -59,16 +59,6 @@ AC_ARG_ENABLE(libio, dnl
fi],
stdio=default)
-AC_ARG_ENABLE(new-malloc, dnl
-[ --enable-new-malloc use the new malloc implementation. This is the
- default for Linux, others use the old malloc.],
- [if test $enableval = yes; then
- malloc=new-malloc
- else
- malloc=malloc
- fi],
- malloc=default)
-
AC_ARG_ENABLE(sanity-checks, dnl
[ --disable-sanity-checks really do not use threads (should not be used
except in special situations) [default=yes]],
@@ -736,15 +726,6 @@ default) stdio=stdio ;;
esac
AC_MSG_RESULT($stdio)
-AC_MSG_CHECKING(malloc selection)
-AC_SUBST(malloc)
-case $malloc in
-new-malloc) USE_NEW_MALLOC=-DUSE_NEW_MALLOC ;;
-default) malloc=malloc ;;
-esac
-AC_SUBST(USE_NEW_MALLOC)
-AC_MSG_RESULT($malloc)
-
AC_SUBST(libc_cv_slibdir)
AC_SUBST(libc_cv_sysconfdir)
AC_SUBST(libc_cv_rootsbindir)