summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b2727d54f2..734c5ad324 100644
--- a/configure.in
+++ b/configure.in
@@ -451,7 +451,7 @@ cat > conftest.s <<EOF
${libc_cv_asm_global_directive} foo
foo: .long 0
.weakext foo
-.weak bar, foo
+.weakext bar, foo
EOF
if ${CC-cc} $CFLAGS -c conftest.s 2>/dev/null; then
libc_cv_asm_weakext_directive=yes
@@ -463,9 +463,9 @@ EOF
fi # no .weak
fi # not ELF
-if test $libc_cv_asm_weak_directive; then
+if test $libc_cv_asm_weak_directive = yes; then
AC_DEFINE(HAVE_ASM_WEAK_DIRECTIVE)
-elif test $libc_cv_asm_weakext_directive; then
+elif test $libc_cv_asm_weakext_directive = yes; then
AC_DEFINE(HAVE_ASM_WEAKEXT_DIRECTIVE)
fi