summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 4aeeae047a..5f6dae1ed7 100644
--- a/configure.in
+++ b/configure.in
@@ -84,8 +84,12 @@ AC_ARG_ENABLE(add-ons, dnl
[ --enable-add-ons[=DIR1,DIR2]... configure and build add-ons in DIR1,DIR2,...
search for add-ons if no parameter given],
[case "$enableval" in
- yes) add_ons=`echo $srcdir/*/configure | \
- sed -e "s!$srcdir/!!g" -e 's!/configure!!g'`;;
+ yes) if test "$srcdir" = "."; then
+ add_ons=`echo */configure | sed -e 's!/configure!!g'`
+ else
+ add_ons=`echo $srcdir/*/configure | \
+ sed -e "s!^$srcdir/!!g" -e 's!/configure!!g'`
+ fi;;
*) add_ons=`echo "$enableval" | sed 's/,/ /g'`;;
esac],
[add_ons=])
@@ -144,7 +148,7 @@ if test -z "$enable_hacker_mode"; then
echo "*** So far nobody cared to port it and if there is no volunteer it"
echo "*** might never happen. So, if you have interest to see glibc on"
echo "*** this platform visit"
- echo "*** http://www.gnu.ai.mit.edu/software/libc/porting.html"
+ echo "*** http://www.gnu.org/software/libc/porting.html"
echo "*** and join the group of porters"
exit 1
;;