summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index a06fa35db2..667ac7e0c2 100644
--- a/configure.in
+++ b/configure.in
@@ -703,10 +703,10 @@ for dir in $sysnames; do
fi
[
if test -z "$uname"; then
- if test -r $sysdep_dir/$dir/uname.c ||
- test -r $sysdep_dir/$dir/uname.S ||
- { test -r $sysdep_dir/$dir/syscalls.list &&
- grep '^uname[ ]' $sysdep_dir/$dir/syscalls.list >/dev/null; }; then
+ if test -r $dest/uname.c ||
+ test -r $dest/uname.S ||
+ { test -r $dest/syscalls.list &&
+ grep '^uname[ ]' $dest/syscalls.list >/dev/null; }; then
uname=$dir
fi
fi
@@ -717,7 +717,7 @@ AC_LINK_FILES(`echo $libc_link_sources`, `echo $libc_link_dests`)
# If we will use the generic uname implementation, we must figure out what
# it will say by examining the system, and write the results in config-name.h.
-if test "$uname" = generic; then
+if test "$uname" = "sysdeps/generic"; then
changequote(,)dnl
uname_sysname=`echo $config_os | sed 's/[0-9.]*$//'`