summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a2668b9ff9..8939236641 100644
--- a/configure.in
+++ b/configure.in
@@ -497,6 +497,23 @@ fi
rm -f conftest*])
AC_SUBST(libc_cv_ld_no_whole_archive)dnl
+AC_CACHE_CHECK(for gcc -fno-exceptions, libc_cv_gcc_no_exceptions, [dnl
+cat > conftest.c <<\EOF
+_start () {}
+int __eh_pc;
+__throw () {}
+EOF
+dnl No \ in command here because it ends up inside ''.
+if AC_TRY_COMMAND([${CC-cc} $CFLAGS
+ -nostdlib -nostartfiles -fno-exceptions
+ -o conftest conftest.c]); then
+ libc_cv_gcc_no_exceptions=yes
+else
+ libc_cv_gcc_no_exceptions=no
+fi
+rm -f conftest*])
+AC_SUBST(libc_cv_gcc_no_exceptions)dnl
+
### End of automated tests.
### Now run sysdeps configure fragments.