summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f3e97798e6..8b797c792e 100644
--- a/configure.in
+++ b/configure.in
@@ -75,6 +75,9 @@ AC_ARG_ENABLE(profile, dnl
AC_ARG_ENABLE(omitfp, dnl
[ --enable-omitfp build undebuggable optimized library [default=no]],
omitfp=$enableval, omitfp=no)
+AC_ARG_ENABLE(bounded, dnl
+[ --enable-bounded build with runtime bounds checking [default=no]],
+ bounded=$enableval, bounded=no)
dnl Generic infrastructure for drop-in additions to libc.
AC_ARG_ENABLE(add-ons, dnl
@@ -755,6 +758,7 @@ if test $shared = default; then
fi
AC_SUBST(profile)
AC_SUBST(omitfp)
+AC_SUBST(bounded)
AC_SUBST(DEFINES)