summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 28314ca5a4..e6f044bc69 100644
--- a/configure.in
+++ b/configure.in
@@ -41,13 +41,13 @@ dnl Arguments to enable or disable building the shared, profiled, and
dnl -fomit-frame-pointer libraries.
AC_ARG_ENABLE(shared, dnl
[ --enable-shared build shared library [default=yes if GNU ld & ELF]],
- shared=yes, shared=no, shared=default)
+ shared=$enableval, shared=default)
AC_ARG_ENABLE(profile, dnl
[ --enable-profile build profiled library [default=yes]],
- profile=yes, profile=no, profile=yes)
+ profile=$enableval, profile=yes)
AC_ARG_ENABLE(omitfp, dnl
[ --enable-omitfp build undebuggable optimized library [default=no]],
- omitfp=yes, omitfp=no, omitfp=no)
+ omitfp=$enableval, omitfp=no)
AC_CANONICAL_HOST
# We keep the original values in `$config_*' and never modify them, so we