summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 014e09a5d5..62ca733b70 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,8 @@ AC_DEFINE_UNQUOTED([PKGVERSION], ["$PKGVERSION"],
AC_DEFINE_UNQUOTED([REPORT_BUGS_TO], ["$REPORT_BUGS_TO"],
[Bug reporting address])
-# Glibc should not depend on any header files
+# Do not make decisions based on the host system's C library, as we must be
+# independent of it.
AC_DEFUN([_AC_INCLUDES_DEFAULT_REQUIREMENTS],
[m4_divert_text([DEFAULTS],
[ac_includes_default='/* none */'])])
@@ -283,10 +284,10 @@ AC_ARG_ENABLE([all-warnings],
AC_SUBST(all_warnings)
AC_ARG_ENABLE([werror],
- AC_HELP_STRING([--disable-werror],
- [do not build with -Werror]),
+ AC_HELP_STRING([--enable-werror],
+ [build with -Werror]),
[enable_werror=$enableval],
- [enable_werror=yes])
+ [enable_werror=no])
AC_SUBST(enable_werror)
AC_ARG_ENABLE([multi-arch],