summaryrefslogtreecommitdiff
path: root/sysdeps/x86_64/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-10-09 16:03:48 +0000
committerJoseph Myers <joseph@codesourcery.com>2015-10-09 16:03:48 +0000
commitae5d8eaed0b56ed72726ce78173a855b5c166d51 (patch)
tree0e78f13018a7926dfee7cc1cbe96527449b4c4bf /sysdeps/x86_64/configure.ac
parentb7848899a591a9de23db6afeb9992668ef8aff88 (diff)
Remove configure tests for -mno-vzeroupper support.
GCC added support for -mno-vzeroupper in version 4.6. Thus the configure tests for this support are obsolete, and this patch removes them. Tested for x86_64 and x86 (testsuite, and that installed stripped shared libraries are unchanged by this patch). * sysdeps/i386/configure.ac (libc_cv_cc_novzeroupper): Remove configure test. * sysdeps/i386/configure: Regenerated. * sysdeps/x86_64/configure.ac (libc_cv_cc_novzeroupper): Remove configure test. * sysdeps/x86_64/configure: Regenerated. * sysdeps/x86_64/Makefile [$(config-cflags-novzeroupper) = yes]: Make code unconditional.
Diffstat (limited to 'sysdeps/x86_64/configure.ac')
-rw-r--r--sysdeps/x86_64/configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/sysdeps/x86_64/configure.ac b/sysdeps/x86_64/configure.ac
index 965ebc95a1..14b9580c66 100644
--- a/sysdeps/x86_64/configure.ac
+++ b/sysdeps/x86_64/configure.ac
@@ -30,14 +30,6 @@ if test $libc_cv_cc_avx512 = yes; then
fi
LIBC_CONFIG_VAR([config-cflags-avx512], [$libc_cv_cc_avx512])
-dnl Check if -mno-vzeroupper works.
-AC_CACHE_CHECK(for -mno-vzeroupper support, libc_cv_cc_novzeroupper, [dnl
-LIBC_TRY_CC_OPTION([-mno-vzeroupper],
- [libc_cv_cc_novzeroupper=yes],
- [libc_cv_cc_novzeroupper=no])
-])
-LIBC_CONFIG_VAR([config-cflags-novzeroupper], [$libc_cv_cc_novzeroupper])
-
dnl Check whether asm supports Intel MPX
AC_CACHE_CHECK(for Intel MPX support, libc_cv_asm_mpx, [dnl
cat > conftest.s <<\EOF