summaryrefslogtreecommitdiff
path: root/sysdeps/x86_64/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2017-06-28 11:31:50 +0000
committerJoseph Myers <joseph@codesourcery.com>2017-06-28 11:31:50 +0000
commit073e8fa7739ed453d6854b834f290c263a6cdb9f (patch)
treefc1843818165783aec3c58997a75e2991a6a1550 /sysdeps/x86_64/configure.ac
parentf300dc7358e785dd92259514f57acd10f695d142 (diff)
Require binutils 2.25 or later to build glibc.
This patch implements a requirement of binutils >= 2.25 (up from 2.22) to build glibc. Tests for 2.24 or later on x86_64 and s390 are removed. It was already the case, as indicated by buildbot results, that 2.24 was too old for building tests for 32-bit x86 (produced internal linker errors linking elf/tst-gnu2-tls1mod.so). I don't know if any configure tests for binutils features are obsolete given the increased version requirement. Tested for x86_64. * configure.ac (AS): Require binutils 2.25 or later. (LD): Likewise. * configure: Regenerated. * sysdeps/s390/configure.ac (AS): Remove version check. * sysdeps/s390/configure: Regenerated. * sysdeps/x86_64/configure.ac (AS): Remove version check. * sysdeps/x86_64/configure: Regenerated. * manual/install.texi (Tools for Compilation): Document requirement for binutils 2.25 or later. * INSTALL: Regenerated.
Diffstat (limited to 'sysdeps/x86_64/configure.ac')
-rw-r--r--sysdeps/x86_64/configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/sysdeps/x86_64/configure.ac b/sysdeps/x86_64/configure.ac
index 7d8aaafc0c..fa86e953ee 100644
--- a/sysdeps/x86_64/configure.ac
+++ b/sysdeps/x86_64/configure.ac
@@ -1,12 +1,6 @@
GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
# Local configure fragment for sysdeps/x86_64.
-dnl Accept as 2.24 or newer for AVX512 load and store.
-AC_CHECK_PROG_VER(AS, $AS, --version,
- [GNU assembler.* \([0-9]*\.[0-9.]*\)],
- [2.2[4-9]*|2.[3-9][0-9]*|[3-9].*|[1-9][0-9]*],
- critic_missing="$critic_missing The program AS is required in version >= 2.24 for target x86_64.")
-
dnl Check if asm supports AVX512DQ.
AC_CACHE_CHECK(for AVX512DQ support in assembler, libc_cv_asm_avx512dq, [dnl
cat > conftest.s <<\EOF