summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2012-05-14 22:22:52 +0000
committerJoseph Myers <joseph@codesourcery.com>2012-05-14 22:22:52 +0000
commit37f1abd46c22a13e7c2492ce9de18f4cc2ca308f (patch)
treeb30146ce737e63e8258716f8b46e46957d06a7d7 /sysdeps/unix/sysv/linux/configure.in
parent11de3a3371c18b6fe955d4b43071656baf4b8804 (diff)
Improve consistency of --enable-kernel and default builds.
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in26
1 files changed, 11 insertions, 15 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
index 1ce14f294f..72fbe8422b 100644
--- a/sysdeps/unix/sysv/linux/configure.in
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -87,29 +87,25 @@ if test -n "$minimum_kernel"; then
minimum_kernel=$arch_minimum_kernel
fi
else
- if test $arch_minimum_kernel != '2.2.0'; then
- minimum_kernel=$arch_minimum_kernel
- fi
+ minimum_kernel=$arch_minimum_kernel
fi
-if test -n "$minimum_kernel"; then
- AC_MSG_CHECKING(for kernel header at least $minimum_kernel)
+AC_MSG_CHECKING(for kernel header at least $minimum_kernel)
changequote(,)dnl
- decnum=`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/(\1 * 65536 + \2 * 256 + \3)/'`;
- abinum=`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1,\2,\3/'`;
+decnum=`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/(\1 * 65536 + \2 * 256 + \3)/'`;
+abinum=`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\1,\2,\3/'`;
changequote([,])dnl
- AC_EGREP_CPP([eat flaming death], [#include <linux/version.h>
+AC_EGREP_CPP([eat flaming death], [#include <linux/version.h>
#if LINUX_VERSION_CODE < $decnum
eat flaming death
#endif], libc_minimum_kernel='too old!', libc_minimum_kernel=ok)
- AC_MSG_RESULT($libc_minimum_kernel)
- if test "$libc_minimum_kernel" = ok; then
- AC_DEFINE_UNQUOTED(__LINUX_KERNEL_VERSION, $decnum)
- AC_DEFINE_UNQUOTED(__ABI_TAG_VERSION, $abinum)
- else
- AC_MSG_ERROR([*** The available kernel headers are older than the requested
+AC_MSG_RESULT($libc_minimum_kernel)
+if test "$libc_minimum_kernel" = ok; then
+ AC_DEFINE_UNQUOTED(__LINUX_KERNEL_VERSION, $decnum)
+ AC_DEFINE_UNQUOTED(__ABI_TAG_VERSION, $abinum)
+else
+ AC_MSG_ERROR([*** The available kernel headers are older than the requested
*** compatible kernel version])
- fi
fi
# The result of the above test for the use of the FDE code is invalid if