summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2002-10-16 03:03:00 +0000
committerRoland McGrath <roland@gnu.org>2002-10-16 03:03:00 +0000
commitabe7b661ff7a361c9fe11789bab068e44de849b0 (patch)
tree2d1f05a2896d87ddeb83d344b2dc1c818a392149 /sysdeps/unix/sysv/linux/configure.in
parentc55dca8d85b4585f3e72eb72a9c1164568a68472 (diff)
Jakub Jelinek <jakub@redhat.com>
* sysdeps/unix/sysv/linux/Makefile ($(objpfx)syscall-%.h $(objpfx)syscall-%.d): Take code from sparc/Makefile to produce a bi-arch file as needed. That's now parameterized by the variable $(64bit-predefine). Use LC_ALL=C for `comm' commands in that rule. No longer conditional on [$(no_syscall_list_h)]. * sysdeps/unix/sysv/linux/sparc/Makefile: Remove replacement rules. (64bit-predefine): New variable. * sysdeps/unix/sysv/linux/x86_64/Makefile: Likewise. * sysdeps/unix/sysv/linux/s390/Makefile: New file. * sysdeps/unix/sysv/linux/powerpc/Makefile (64bit-predefine): New variable. 2002-10-15 Roland McGrath <roland@redhat.com> * sysdeps/unix/sysv/linux/Makefile ($(objpfx)syscall-%.h $(objpfx)syscall-%.d) * login/utmp-private.h: Declare __libc_utmp_lock. * sysdeps/unix/getlogin_r.c (getlogin_r): Take __libc_utmp_lock once call __libc_utmp_jump_table functions directly, instead of using __setutent et al. * sysdeps/unix/sysv/linux/configure.in: Use case instead of if. * sysdeps/unix/sysv/linux/configure: Regenerated.
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in19
1 files changed, 11 insertions, 8 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
index 95c3c620f5..ac900da36c 100644
--- a/sysdeps/unix/sysv/linux/configure.in
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -152,20 +152,22 @@ fi
# files. I.e., when the installation prefix is "/usr" we have to place
# shared library objects and the configuration files on the root partition
# in /lib and /etc.
-if test "$prefix" = "/usr" -o "$prefix" = "/usr/"; then
- # 64bit libraries on sparc go to /lib64 and not /lib
- if test "$machine" = "sparc/sparc64" -o "$machine" = "x86_64" \
- -o "$machine" = "powerpc/powerpc64" \
- -o "$machine" = "s390/s390-64"; then
+case "$prefix" in
+/usr | /usr/)
+ # 64-bit libraries on bi-arch platforms go in /lib64 instead of /lib
+ case $machine in
+ sparc/sparc64 | x86_64 | powerpc/powerpc64 | s390/s390-64 )
libc_cv_slibdir="/lib64"
if test "$libdir" = '${exec_prefix}/lib'; then
libdir='${exec_prefix}/lib64';
# Locale data can be shared between 32bit and 64bit libraries
libc_cv_localedir='${exec_prefix}/lib/locale'
fi
- else
+ ;;
+ *)
libc_cv_slibdir="/lib"
- fi
+ ;;
+ esac
# Allow the user to override the path with --sysconfdir
if test $sysconfdir = '${prefix}/etc'; then
libc_cv_sysconfdir=/etc
@@ -173,7 +175,8 @@ if test "$prefix" = "/usr" -o "$prefix" = "/usr/"; then
libc_cv_sysconfdir=$sysconfdir
fi
libc_cv_rootsbindir="/sbin"
-fi
+ ;;
+esac
# Under Linux the LinuxThreads or NPTL add-on should be available.
case $add_ons in