summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-06-10 09:41:16 +0000
committerRoland McGrath <roland@gnu.org>1996-06-10 09:41:16 +0000
commit564210fe2fdf88dd0800590b256cdb0751da1dec (patch)
tree403cf41f67bdc836d9efc65b6618a8951d815b7d /sysdeps/unix/sysv/linux/configure.in
parent6d9756c910a07bb353af4d6908f88c1ddea15916 (diff)
Mon Jun 10 02:22:24 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu>
* sysdeps/unix/sysv/linux/configure.in: New file, start with configure. Add check for installed <linux/version.h> being v2.0 or later. * sysdeps/generic/dl-sysdep.c (_dl_sysdep_open_zero_fill): Call __open instead of open. (_dl_sysdep_fatal): Call __write instead of write. (_dl_sysdep_message): Likewise. Sun Jun 9 20:40:00 1996 Andreas Schwab <schwab@issan.informatik.uni-dortmund.de> * sysdeps/m68k/fpu/e_acosl.c: New file. * Makerules (o-objects): New variable. Use it in place of $(objects:.o=$o); it filters out $(elide-routines$o). Use o-iterator for ar and ranlib rules so they use the per-type object list. * sysdeps/unix/bsd/ultrix4/sys/mman.h: Likewise.
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
new file mode 100644
index 0000000000..5686c26153
--- /dev/null
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -0,0 +1,25 @@
+sinclude(./aclocal.m4)dnl Autoconf lossage
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+# Local configure fragment for sysdeps/unix/sysv/linux.
+
+# On Linux, the default is to use libio instead of stdio.
+test $stdio = default && stdio=libio
+
+# Don't bother trying to generate any glue code to be compatible with the
+# existing system library, because we are the only system library.
+inhibit_glue=yes
+
+AC_CACHE_CHECK(installed Linux kernel header files, libc_cv_linux2, [dnl
+AC_TRY_COMPILE([#include <linux/version.h>],
+[#if LINUX_VERSION_CODE < (2 *65536+ 0 *256+ 0) /* 2.0.0 */
+eat flaming death
+#endif],
+ libc_cv_linux2='2.0 or later', libc_cv_linux2='TOO OLD!')])
+if test "$libc_cv_linux2" != '2.0 or later'; then
+ AC_MSG_ERROR([GNU libc requires kernel header files from Linux 2.0
+or later to be installed before configuring. The kernel header files
+are found usually in /usr/include/asm and /usr/include/linux; make sure
+these directories use files from Linux 2.0 or later. This check uses
+<linux/version.h>, so make sure that file was built correctly when
+installing the kernel header files.])
+fi