summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.de>2001-07-06 09:21:36 +0000
committerAndreas Jaeger <aj@suse.de>2001-07-06 09:21:36 +0000
commit7f2826c8361156ee387b5f1cfb5f4513c0af5554 (patch)
tree2c622f0554f3af8758ca1bdbce833e79c6d2ad0b /sysdeps/unix/sysv/linux/configure.in
parent513eb02f81cc5cd1eee48fe51d7fc5bd2c53ca9f (diff)
Update.
* manual/libc-texinfo.sh: Add note for the FDL. * manual/argp.texi (Argp Example 4): Fix texinfo warning. * manual/libc.texinfo: Regenerated. * manual/fdl.texi: Fix node.
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in32
1 files changed, 17 insertions, 15 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
index afe798218a..b112a0f4fb 100644
--- a/sysdeps/unix/sysv/linux/configure.in
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -39,11 +39,8 @@ fi
# kernel headers are young enough. Additionally we have minimal
# kernel versions for some architectures.
case "$machine" in
- mips*)
- arch_minimum_kernel=2.2.15
- ;;
- sh*)
- arch_minimum_kernel=2.3.99
+ alpha*)
+ arch_minimum_kernel=2.1.100
;;
ia64*)
arch_minimum_kernel=2.4.0
@@ -51,6 +48,12 @@ case "$machine" in
hppa*)
arch_minimum_kernel=2.3.99
;;
+ mips*)
+ arch_minimum_kernel=2.2.15
+ ;;
+ sh*)
+ arch_minimum_kernel=2.3.99
+ ;;
*)
arch_minimum_kernel=2.0.10
;;
@@ -122,27 +125,26 @@ fi
case $add_ons in
# It is available. Good.
*linuxthreads*)
- message=
+ linuxthreads_missing=
;;
*)
- message="\
-*** WARNING: Are you sure you do not want to use the \`linuxthreads'
-*** add-on?"
+ linuxthreads_missing=yes
;;
esac
-if test "$message"; then
+if test "$linuxthreads_missing"; then
if test $enable_sanity = yes; then
echo "\
-*** You should not compile the GNU libc without the \`linuxthreads'
-*** add-on. Not using them risks being incompatible with the
-*** libraries of other systems. Consider getting the add-on and restarting
-*** the configuration.
+*** On GNU/Linux systems it is normal to compile GNU libc with the
+*** \`linuxthreads' add-on. Without that, the library will be
+*** incompatible with normal GNU/Linux systems.
*** If you really mean to not use this add-on, run configure again
*** using the extra parameter \`--disable-sanity-checks'."
exit 1
else
- echo "$message"
+ echo "\
+*** WARNING: Are you sure you do not want to use the \`linuxthreads'
+*** add-on?"
fi
fi