summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1999-05-29 22:56:42 +0000
committerUlrich Drepper <drepper@redhat.com>1999-05-29 22:56:42 +0000
commitfc0a2d72e5d12276e97f6b581a54561c239872f8 (patch)
tree273b00ac047ec609aa1199b7ca34f893751e5885 /sysdeps/unix/sysv/linux/configure.in
parentfb97136391ea0e5a1774c830a7bf08ef004d9d66 (diff)
Update.
1999-05-27 Andreas Schwab <schwab@issan.cs.uni-dortmund.de> * malloc/malloc.h: Properly handle future GCC versions. 1999-05-27 Andreas Schwab <schwab@issan.cs.uni-dortmund.de> * sysdeps/unix/sysv/linux/configure.in: Change version checks to use AC_EGREP_CPP. Change sed pattern to not use alternation. Fix text of error message. * aclocal.m4 (GLIBC_PROVIDES): Define AC_LANG to `C'.
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in26
1 files changed, 10 insertions, 16 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
index 021b4731eb..3f3d02131a 100644
--- a/sysdeps/unix/sysv/linux/configure.in
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -16,14 +16,14 @@ if test -n "$sysheaders"; then
fi
define([libc_cv_linuxVER], [libc_cv_linux]patsubst(LIBC_LINUX_VERSION,[\.]))dnl
AC_CACHE_CHECK(installed Linux kernel header files, libc_cv_linuxVER, [dnl
-AC_TRY_COMPILE([#include <linux/version.h>],
-[#if LINUX_VERSION_CODE < ]dnl
+AC_EGREP_CPP([eat flaming death], [#include <linux/version.h>
+#if !defined LINUX_VERSION_CODE || LINUX_VERSION_CODE < ]dnl
patsubst(LIBC_LINUX_VERSION,[^\([^.]*\)\.\([^.]*\)\.\([^.]*\)$],dnl
[ (\1 *65536+ \2 *256+ \3) /* \1.\2.\3 */])[
eat flaming death
#endif],
- libc_cv_linuxVER='LIBC_LINUX_VERSION or later',
- libc_cv_linuxVER='TOO OLD!')])
+ libc_cv_linuxVER='TOO OLD!',
+ libc_cv_linuxVER='LIBC_LINUX_VERSION or later')])
if test "$libc_cv_linuxVER" != 'LIBC_LINUX_VERSION or later'; then
AC_MSG_ERROR([GNU libc requires kernel header files from
Linux LIBC_LINUX_VERSION or later to be installed before configuring.
@@ -40,25 +40,19 @@ fi
if test -n "$minimum_kernel"; then
AC_MSG_CHECKING(for kernel header at least $minimum_kernel)
changequote(,)dnl
- decnum=`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\(\([0-9]*\)\|\).*/(\1 * 65536 + \2 * 256 + \3)/'`;
+ decnum=`echo "$minimum_kernel.0.0.0" | sed 's/\([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/(\1 * 65536 + \2 * 256 + \3)/'`;
changequote([,])dnl
- cat > conftest.$ac_ext <<EOF
-#include <linux/version.h>
-int main() {
+ AC_EGREP_CPP([eat flaming death], [#include <linux/version.h>
#if LINUX_VERSION_CODE < $decnum
eat flaming death
-#endif
-; return 0; }
-EOF
- if { (eval echo configure:30: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+#endif], libc_minimum_kernel='too old!', libc_minimum_kernel=ok)
+ AC_MSG_RESULT($libc_minimum_kernel)
+ if test "$libc_minimum_kernel" = ok; then
AC_DEFINE_UNQUOTED(__LINUX_KERNEL_VERSION, $decnum)
- AC_MSG_RESULT(ok)
else
- AC_MSG_RESULT(too old!)
- AC_MSG_ERROR([*** The available kernel headers are not at least as old as the requested
+ AC_MSG_ERROR([*** The available kernel headers are older than the requested
*** compatible kernel version])
fi
- rm -f conftest*
fi
if test -n "$sysheaders"; then